PHP is one of the most commonly used open-source server-side programming languages. It is quite popular as it’s free software, which can be used to create responsive websites such as community web portals, e-stores or school websites instead of static HTML sites. A PHP module must be activated on the web server where a PHP-driven site is hosted so that its source code can be interpreted. Because there aren’t any license fees for this type of module and the language provides unlimited options for the applications that you create, there’re 100s of millions of PHP-driven websites. On top of that, there are lots of open-source PHP-based scripts, which you can use for your sites without needing to possess any coding knowledge. Since there’re different PHP versions, you ought to confirm whether the same version that you used while creating your site is installed on the server too.

PHP 4, PHP 5 and PHP 7 Support in Cloud Hosting

If you get a cloud hosting package from our company, you will never need to question yourself on whether your sites are compatible with the hosting environment, since several versions of PHP are available on our servers for the sake of your convenience. The Hepsia hosting Control Panel will permit you to choose PHP 4, PHP 5 and PHP 7 with only one click of the mouse and in case you need to change the current version, the update will be applied instantly. Thus, many years of work on websites built with an older version will not be lost. Our web hosting platform will even permit you to use a different PHP version for each domain name hosted in your account, which suggests that you can use older and newer scripts at the same time. Most web hosting providers on the market support one, sometimes two PHP versions. In contrast to them, we consider that you should be the one to pick the version that will be used by your very own sites.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Hosting

In case you’ve got a site based on an earlier version of PHP and you’ve put time and energy towards developing it, filling safety gaps and inputting page content, you’ll need a web hosting service that can support it, since the majority of web hosting companies nowadays support only the most recently released PHP version and drop the earlier versions. We, however, have decided to allow you to pick the version that your very own sites require. Our Linux semi-dedicated hosting support PHP 4, PHP 5 and PHP 7, which means that you’ll be able to run both newer and older scripts without forfeiting any custom tweaks or frittering away time and efforts struggling to make your websites compatible with the web hosting platform. The version can be changed from the Hepsia Control Panel and such a change will apply to the entire semi-dedicated server account, but you will also be able to pick a different PHP version for each individual website that you host in your account by using an .htaccess file.